Opened 13 years ago

Closed 13 years ago

#1079 closed defect (invalid)

Raw data import takes very long time to fail when user exceeds quota

Reported by: Jari Häkkinen Owned by: everyone
Priority: major Milestone:
Component: coreplugins Version: 2.7.2
Keywords: Cc:

Description

Raw data imports that usually takes 30-40 seconds to successfully store data in the database take more than 15 minutes to fail when a user exceeds his quota. At the same time the server has a lot of wait state, http://en.wikipedia.org/wiki/Wait_state, time. The wait state seems to go down after the failed import finalizes.

This issue should be examined since our server becomes sluggish during this sort of quota-breaking imports that fail anyhow.

Change History (3)

comment:1 Changed 13 years ago by Nicklas Nordborg

I just tested this on my development machine, and the failure happened immediately. Is it reproducible on the server where this happened? Does this only happen when there is not enough quota, or does it happen for other import errors as well (for example, a missing reporter)?

My best guess is that it is the rollback on the database that is taking a long time, because after a failure the only thing that happens in the BASE code is a rollback of the transaction. Maybe it is some kind of locking issue where the database must wait for a time-out, though that usually happens when trying to commit a transaction.

comment:2 Changed 13 years ago by Nicklas Nordborg

To get information about what is happening during those 15 minutes it should be possible to do:

kill -QUIT <process-id>

This will cause the Java process to print out the stacktrace of all thread. To output will go to the standard output of the Java process, not to the console. NOTE! this command will not kill the process.

comment:3 Changed 13 years ago by Nicklas Nordborg

Resolution: invalid
Status: newclosed

Closing this ticket since no feedback has been provided.

Note: See TracTickets for help on using tickets.