Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#1066 closed enhancement (fixed)

Reset all filters functionality request

Reported by: Jari Häkkinen Owned by: Nicklas Nordborg
Priority: minor Milestone: BASE 2.8
Component: web Version: trunk
Keywords: Cc:

Description

In some cases filtering of list views and inclusion of columns to list views make the web interface to seriously break. 'seriously' means that there is no way to remove the filer due to different reasons, two examples are a list view is always blank because of exceptions and ItemNotFoundException: Item not found: ExtraValue[id=44] message can not be cleared.

So, I suggest to add a reset filter function to the web interface in the file tab: File -> Reset filters. Resetting all filters may be a very blunt tool but this is sometimes the only way out. One could imaging to have File -> Reset ... that allows the user to select what to reset but then we need to define different levels. The above examples are filters for spot data views for bioassays.

Change History (5)

comment:1 Changed 13 years ago by Nicklas Nordborg

I think we can have two levels:

  • Reset in-memory settings
  • Reset in-database settings

The first is useful if the problem is discovered immediately. Changes are not saved to the database until a user is logging out.

comment:2 Changed 13 years ago by Nicklas Nordborg

Milestone: BASE 2.8
Owner: changed from everyone to Nicklas Nordborg
Priority: majorminor
Status: newassigned

comment:3 Changed 13 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [4376]) Fixes #1066: Reset all filters functionality request

comment:4 Changed 13 years ago by Nicklas Nordborg

(In [4377]) References #1066: Reset all filters functionality request

Added missing file.

comment:5 Changed 13 years ago by Nicklas Nordborg

(In [4409]) References #1066: Reset all filters functionality request

Fixed incorrect tooltip message.

Note: See TracTickets for help on using tickets.