Opened 10 years ago

Closed 10 years ago

#917 closed enhancement (fixed)

The progress reporter for a job should update the database if the progress is increased with >= 5%

Reported by: nicklas Owned by: nicklas
Priority: minor Milestone: BASE 2.6
Component: core Version:
Keywords: Cc:

Description

The current rule is that the progress is only updated if at least 5 seconds has passed since the last update. Some plug-ins (for example the Base1PluginExecuter) cannot do the update at regular intervals. It usually waits at 10% when the external plug-in code is executing. The problem is that the time taken to get to that point is usually less than 5 seconds and the progress that the user sees says: 0%, Exporing data...

So, I think if the progress is increased by at least 5% the database should always be updated. It should not cause any performance degradation, since at most 20 such updates can happen.

Change History (2)

comment:1 Changed 10 years ago by nicklas

  • Owner changed from everyone to nicklas
  • Status changed from new to assigned

comment:2 Changed 10 years ago by nicklas

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [4123]) Fixes #917: The progress reporter for a job should update the database if the progress is increased with >= 5%

Note: See TracTickets for help on using tickets.