Opened 10 years ago

Closed 10 years ago

#910 closed defect (fixed)

Plug-ins ignore file set by the auto-detect file format function

Reported by: nicklas Owned by: nicklas
Priority: major Milestone: BASE 2.6
Component: web Version:
Keywords: Cc:

Description

This happens in the ReporterMapImporter? and in the RawDataFlatFileImporter?. I don't know if it happens in other plug-ins as well. I guess the problem is in the web client which forgets the file that was selected in the auto-detection step.

  1. Create an array design and select file 'A' as the reporter map file. This file can be any file that doesn't match a configured file format.
  2. Click on the "Import" button and select auto-detect. The 'A' file should already be selected in the 'File' field.
  3. Click on 'Browse...' and select file 'B' instead. This file should match a defined reporter map file format.
  4. Click on 'Next...'
  5. If a file format is found a new page showing more parameters is displayed
  6. Select 'Reporter map file' parameter.
  7. The value of this parameter is the 'A' file.

Workarounds:

  1. Click on 'Browse...' in the last window and select the 'B' file again.
  2. Don't select file 'A' as a reporter map file in step 1 above.

Change History (2)

comment:1 Changed 10 years ago by nicklas

  • Owner changed from everyone to nicklas
  • Status changed from new to assigned

The reason for this behavior is that if a file is already selected as the 'reporter map' file the plug-in sets this file as the default value. This has higher precedence than the most recently used file in CurrentContext? which is where the auto-detected file is stored. I guess the priority order should be:

  1. The auto-detected file
  2. The default value
  3. Any other recently used file

The problem is entirely in the web client code.

comment:2 Changed 10 years ago by nicklas

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [4111]) Fixes #910: Plug-ins ignore file set by the auto-detect file format function

Note: See TracTickets for help on using tickets.