Opened 10 years ago

Closed 10 years ago

#889 closed defect (fixed)

Clicking "Help" throws a Python error

Reported by: base Owned by: martin
Priority: minor Milestone: BASE 2.6
Component: web Version: 2.5.0
Keywords: Cc:

Description (last modified by nicklas)

http://base2.thep.lu.se/demo/ BASE 2.5.0beta (build #3933; schema #45)

To reproduce the error, simply: Click on Help, Help.

Traceback (most recent call last):

File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 356, in dispatch_request

dispatcher.dispatch(req)

File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 224, in dispatch

resp = chosen_handler.process_request(req)

File "/usr/lib/python2.4/site-packages/trac/web/chrome.py", line 234, in process_request

raise HTTPNotFound('File %s not found', filename)

HTTPException: 404 Not Found (File doc/docbook/html/index.html not found)

Thanks,

Jay Hannah - jay@… http://clab.ist.unomaha.edu/CLAB/index.php/User:Jhannah

How to fix this issue
The URL for the BASE documentation has changed for administrative reasons. New installations from BASE 2.6 and onwards will get the correct URL installed. Existing servers should be manually updated.

  1. Log in to BASE with administrator privileges
  2. Open the Administrate -> Server settings dialog
  3. Switch to the Links tab and change the Help URL to: http://base.thep.lu.se/chrome/site/latest/html/index.html

Change History (8)

comment:1 Changed 10 years ago by nicklas

  • Milestone set to BASE 2.6

comment:2 Changed 10 years ago by martin

  • Owner changed from everyone to martin
  • Status changed from new to assigned

comment:3 Changed 10 years ago by martin

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [4140]) Fixes #889 Clicking "Help" throws a Python error. Changed an invalid link

comment:4 Changed 10 years ago by nicklas

  • Resolution fixed deleted
  • Status changed from closed to reopened

I think the fix only works for new installations. It will not update the link on existing installations. There are two approaches:

  1. Fix the code so that it updates the link in existing installation.
  2. Document this issue in this ticket and tell user how to manually change the link and what the correct link should be.

comment:5 Changed 10 years ago by martin

A suggestion to cover both.

  1. Similar option like there is for help texts will be put into base.config (server.configurations.update = true|false). Default value for this option will be false.
  2. Documentation - See ticket#930

comment:6 Changed 10 years ago by nicklas

A: is not a very good solution. Users will probably not want to loose their custom made "About the server" text and other settings just to fix the bad link. It will require more work to restore those texts than to manually fix the link as in B.

B: There should be a note in this ticket!

Personally I think B is good enough. Just put the correct link in the description part of the ticket (not as a comment since that list is growing large).

comment:7 Changed 10 years ago by martin

  • Description modified (diff)

Added reference to documentation ticket

comment:8 Changed 10 years ago by nicklas

  • Description modified (diff)
  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.