Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#850 closed enhancement (fixed)

SQL for checking schema version in BASE 1 should be externalized

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: major Milestone: BASE 2.5
Component: migrate Version:
Keywords: Cc:

Description

See Migrater.java line 530. The hardcoded SQL statement should be externalized to migration-queries.sql just as all other SQL statements are.

The problem is that the query doesn't work on Postgres and there is no way to modify it without changing the code.

Change History (3)

comment:1 Changed 13 years ago by Nicklas Nordborg

Owner: changed from everyone to Nicklas Nordborg
Status: newassigned

comment:2 Changed 13 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [4032]) Fixes #850: SQL for checking schema version in BASE 1 should be externalized

comment:3 Changed 13 years ago by Nicklas Nordborg

(In [4039]) References #850: SQL for checking schema version in BASE 1 should be externalized

Missed migration-queries.sql in last checkin

Note: See TracTickets for help on using tickets.