Opened 14 years ago

Closed 14 years ago

Last modified 13 years ago

#514 closed task (fixed)

Change permissions in Power User

Reported by: Johan Enell Owned by: Martin Svensson
Priority: major Milestone: BASE 2.4
Component: core Version: trunk
Keywords: Cc:

Description

I think that the permission to create Reporters should be removed from the Power User and only allowed for the Admin.

Change History (7)

comment:1 Changed 14 years ago by Nicklas Nordborg

What is the reason for the change?

When the roles were specified the 'Administrator' role was intended for stuff related to user-account management (users, groups, quota, etc). The 'Power user' was intended as a biological administrator (Array LIMS, annotation types, reporters, etc). The ability to add reporters is needed to be able to create things in the Array LIMS part.

The power user also has plugin admin rights. We discussed splitting this into another role but never came to a decision.

comment:2 Changed 14 years ago by jari

Milestone: BASE 2.4
Owner: changed from Nicklas Nordborg to jari
Status: newassigned

We should think this through.

comment:3 Changed 14 years ago by Nicklas Nordborg

If the permissions for 'Power user' changes the test program(s) at net.sf.basedb.test.roles also need to change, since it assumes that a 'Power user' is able to import reporters. The test that import reporters need to be moved from PowerUserTest?.java to the 'Administrator' part of the test program (AdminTest?.java).

comment:4 Changed 14 years ago by jari

Owner: changed from jari to Martin Svensson
Priority: trivialmajor
Status: assignednew
Type: defecttask

After deep consideration we have decided to remove the create and update reporters privileges from the Poweruser role.

comment:5 Changed 14 years ago by Martin Svensson

Status: newassigned

comment:6 Changed 14 years ago by Martin Svensson

Resolution: fixed
Status: assignedclosed

(In [3665]) Fixes #514 Change permissions in Power User

comment:7 Changed 13 years ago by Nicklas Nordborg

(In [4013]) References #514: Change permissions in Power User

Updated test instructions to say that the admin and not the power user should import the reporters

Note: See TracTickets for help on using tickets.