Opened 4 months ago

Closed 3 months ago

#2104 closed enhancement (fixed)

Job items should use lazy loading

Reported by: nicklas Owned by: everyone
Priority: minor Milestone: BASE 3.12
Component: core Version:
Keywords: Cc:

Description

I have noticed that loading a lot of derived bioassay items that are linked to jobs can take more time than expected. Checking log files (after enabling SQL logging) shows that one SQL SELECT is issued for each job item even if we do not explicitly request the job information. The reason is that jobs have not been configured to use lazy loading.

While the change is simple, we have to look out for problems caused by navigating to the job item after the session has been closed.

Change History (1)

comment:1 Changed 3 months ago by nicklas

  • Resolution set to fixed
  • Status changed from new to closed

(In [7437]) Fixes #2104: Job items should use lazy loading

Note: See TracTickets for help on using tickets.