Opened 2 weeks ago

Closed 2 weeks ago

#2078 closed defect (fixed)

It is not possible to modify an annotation type that has the "Project annotations" flag set when there are existing annotations

Reported by: nicklas Owned by: everyone
Priority: major Milestone: BASE 3.11
Component: web Version:
Keywords: Cc:

Description (last modified by nicklas)

This results in an error message:

Permission denied: Can't set projectAnnotations to FALSE 
since there are 3 existing project-specific annotations.

The is most likely caused by the disabled checkbox which is interpreted as an unchecked checkbox when saving. Since it is not allowed to disable the flag when there are existing annotations an error is thrown.

Change History (2)

comment:1 Changed 2 weeks ago by nicklas

  • Description modified (diff)

comment:2 Changed 2 weeks ago by nicklas

  • Resolution set to fixed
  • Status changed from new to closed

(In [7339]) Fixes #2078: It is not possible to modify an annotation type that has the "Project annotations" flag set when there are existing annotations

Fixed by making sure the checkbox is not disabled before submitting the form.

Note: See TracTickets for help on using tickets.