Opened 4 weeks ago

Closed 4 weeks ago

#2071 closed defect (fixed)

Restart a job from the beginning if it has already been restarted in the middle

Reported by: nicklas Owned by: everyone
Priority: major Milestone: BASE 3.11
Component: core Version:
Keywords: Cc:

Description

The job execution API has support for suspending and resuming a job due to a system shutdown/restart.

Jobs that has support for this sets a "breakpoint" for the job which is stored in the database when the system is shutting down. When the system is up and running again the job is restarted from the stored breakpoint.

The problem is that the stored breakpoint is not cleared. If the user chooses to abort the job and then re-start it, it will continue from the same breakpoint instead of from the beginning.

It would be better if the job re-started from the beginning.

It would be even better to implement functionality for letting the user choose if the job should be restarted from the beginning or from the breakpoint.

Change History (1)

comment:1 Changed 4 weeks ago by nicklas

  • Resolution set to fixed
  • Status changed from new to closed

(In [7317]) Fixes #2071: Restart a job from the beginning if it has already been restarted in the middle

It is now possible to select if a job should be restarted from the beginning or from the stored breakpoint.

Note: See TracTickets for help on using tickets.