Opened 6 years ago

Closed 6 years ago

#1922 closed enhancement (fixed)

Always update BASE version file when compiling

Reported by: Nicklas Nordborg Owned by:
Priority: trivial Milestone: BASE 3.5
Component: build Version:
Keywords: Cc:

Description

Base version information is stored in base.version file. There is a template file in the subversion repository which is copied to the build folder if it is not already there. Then an action in ant is used to replace the template holders with the actual BASE version numbers. The problem is that this file is never updated unless ant clean is executed. This is mostly an annoyance for developers since this file tends to hang around between releases.

Change History (1)

comment:1 Changed 6 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [6727]) Fixes #1922: Always update BASE version file when compiling

Always delete the base.version file in the build directory to force a new version to be created.

Note: See TracTickets for help on using tickets.