Opened 9 years ago

Closed 9 years ago

#1670 closed defect (fixed)

Extensions installer should set current date+time on extracted files

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: critical Milestone: BASE 3.1
Component: web Version:
Keywords: Cc:

Description (last modified by Nicklas Nordborg)

The current implementation set the file date to the last modified date found in the JAR file. The problem is that this approach may cause Tomcat to not detect file changes since the compiled class in the work-directory may have a newer date (for example, due to a server restart).

One workaround is to always restart Tomcat after updating an extension. Another option is to manually 'touch' the JSP files belonging to the extension. Something like:

cd <base-dir>/www/extensions/foo.jar
touch *.jsp

Change History (3)

comment:1 Changed 9 years ago by Nicklas Nordborg

Description: modified (diff)
Owner: changed from everyone to Nicklas Nordborg
Status: newassigned

comment:2 Changed 9 years ago by Nicklas Nordborg

This issue was reported as a Tomcat bug a long time ago, but not fixed until Tomcat 7.0.17. For more information see: https://issues.apache.org/bugzilla/show_bug.cgi?id=33453

comment:3 Changed 9 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [6016]) Fixes #1670: Extensions installer should set current date+time on extracted files

Note: See TracTickets for help on using tickets.