Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#1668 closed defect (fixed)

Internet explorer opens incorrect URL if a popup window already exists

Reported by: Nicklas Nordborg Owned by: everyone
Priority: minor Milestone: BASE 3.1
Component: web Version:
Keywords: Cc:

Description

This only happens for some popup windows. We have found two places so far:

  1. The 'Plot' function in Experiment explorer.
  2. The 'More details' button in Administrate -> Plugins & extensions -> Overview

To reproduce the issue:

  1. Open the popup
  2. Switch back to the BASE main window without closing the popup
  3. Try to open the popup again. Click 'Ok' in the message about the already opened window.
  4. The old popup is replaced with a new one but doesn't display the expected page.
  • The 'Plot' function show a 404 error: HTTP Status 404 - /onk/plotter.jsp
  • The 'More details' button show the login page.

This seems to be a problem with IE only. Firefox is not affected. The workaround is to manually close the popup before trying to open it again.

Change History (2)

comment:1 Changed 9 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [5997]) Fixes #1668: Internet explorer opens incorrect URL if a popup window already exists

I think this issue was caused by the fix to #1660. Seems like the call to to confirm() for some reason must be made with the parentWin object that is later used to open the popup window.

comment:2 Changed 9 years ago by Nicklas Nordborg

(In [6002]) References #1668: Internet explorer opens incorrect URL if a popup window already exists

Do not delay call to focus() since it can interfere with onload event on the new window.

Note: See TracTickets for help on using tickets.