Opened 8 years ago

Closed 7 years ago

Last modified 6 years ago

#1659 closed task (fixed)

Update SvnAnt to a version that support Subversion 1.7

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: minor Milestone: BASE 3.3
Component: build Version:
Keywords: Cc:

Description

Subversion 1.7 was released a some time ago, but there are problems building BASE if the code has been checked out from the svn repository with this version. The problem is that the build process uses svn calls to find out the revision number. The svn calls are made with SvnAnt (http://subclipse.tigris.org/svnant.html) and the current version only supports up to Subversion 1.6.

There is no released SvnAnt version that supports Subversion 1.7 but it seems like the work is in progress. As soon as the new version has been released we should upgrade.

Attachments (1)

svnant-1.4dev-rev-5584.zip (6.2 MB) - added by Nicklas Nordborg 7 years ago.
SvnAnt? 1.4dev-rev-5584

Change History (6)

comment:1 Changed 8 years ago by Nicklas Nordborg

Component: corebuild

comment:2 Changed 7 years ago by Nicklas Nordborg

Milestone: BASE 3.1BASE Future Release

Seems like there is no progress on this one at the moment...

comment:3 Changed 7 years ago by Nicklas Nordborg

Milestone: BASE Future ReleaseBASE 3.3
Owner: changed from everyone to Nicklas Nordborg
Status: newassigned

Still no progress on the development. I have been looking around for some other package. The most promising seems to be https://github.com/opticyclic/svntask but it is lacking support for 'diff' and 'export' commands which we use.

The good news is that the current SvnAnt trunk has support for Subversion 1.7. I have checked out the trunk, compiled it and tested with BASE. It seems to be working with both Subversion 1.6 and Subversion 1.7 working copy format. So, I'll update the current libraries with the ones from the SvnAnt development. Hopefully something official will be released some time in the future.

comment:4 Changed 7 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [6241]) Fixes #1659: Update SvnAnt? to a version that support Subversion 1.7

Note that this is development version of SvnAnt 1.4 checked out from http://subclipse.tigris.org/svn/subclipse/trunk/svnant, revision 5584.

Changed 7 years ago by Nicklas Nordborg

Attachment: svnant-1.4dev-rev-5584.zip added

SvnAnt? 1.4dev-rev-5584

comment:5 Changed 6 years ago by Nicklas Nordborg

(In [6404]) References #1659: Update SvnAnt? to a version that support Subversion 1.7

Fixed an issue with <svn> tag no longer supporting 'dateformatter' attribute. It must now be defined in a <svnSetting> tag that is referenced from the <svn> tag.

And since we only defined the <svn> tag in our build.xml this also needed to be changed so that all svn-related tags and types are imported automatically (by referencing the svnantlib.xml file).

Note: See TracTickets for help on using tickets.