Opened 11 years ago

Closed 11 years ago

#1412 closed defect (fixed)

The selected unit for an annotation type should not be remembered when creating a new annotation type

Reported by: Nicklas Nordborg Owned by: everyone
Priority: minor Milestone: BASE 2.14
Component: web Version:
Keywords: Cc:

Description

To reproduce:

  1. Create a numerical annotation type. Select any quantity and unit on the units tab. Save.
  2. Create a second numerical annotation type. Do not switch to the units tab. Save.
  3. The second annotation type is created with the same quantity as the first annotation.

The problem is that an annotation type that has been given a unit can't be made unit-less. A new annotation type must be created. On the other hand, a unit-less annotation type can be converted to an annotation type with a unit so it is always safer to not assign a unit automatically.

Change History (1)

comment:1 Changed 11 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [5152]) Fixes #1412: The selected unit for an annotation type should not be remembered when creating a new annotation type

Note: See TracTickets for help on using tickets.